PSP NobleQ

PSP NobleQ combines the features of passive program equalizers with a wide range of frequency settings and extended functionality. To make this plug-in a versatile tool, we added several modern features such as an adjustable high pass filter, and the ability to switch the high peak and shelf filters to "Boost" or "Attenuation" modes.

PSP NobleQ stands out for its warm sound, its boost and attenuation low-shelf filters, and its combined peak and shelf high frequency processing. The warm and musical sound in PSP NobleQ is made possible thanks to its finest processing utilizing FAT double sampling for natural, analog-like response. We also added an output valve-like rounding algorithm with adjustable processing depth.

The low shelf filter actually combines two shelving sections: the first one allows you to boost low frequencies while the other one attenuates them, but is tuned slightly higher. Together, they help to get a rich bottom end without low-midrange muddiness.

The high frequency range consists of two filters – a peaking filter with adjustable bandwidth (usually set to Boost) and a shelf filter (usually set to Attenuate). Both filters interact in such a way that the more attenuation to high frequency is applied, the more the selective peaking filter becomes while keeping its center frequency similarly boosted.

PC

VST

  • Windows x32 or x64 (XP Service Pack 2, Vista or 7)

  • VST 2.4 compatible application

RTAS

  • Windows x32 or x64 (XP Service Pack 2, Vista or 7)

  • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

AAX

  • Windows x32 or x64 (XP Service Pack 2, Vista or 7)

  • Pro Tools 10 or Pro Tools 11 (or later)

Mac (intel)

AudioUnit

  • Mac OSX 10.5 or later

  • 32 or 64-bit host application capable of running AudioUnit plug-ins with Cocoa view

VST

  • Mac OSX 10.5 or later

  • 32 or 64-bit VST 2.4 compatible host application

RTAS

  • Mac OSX 10.5 or later

  • ProTools LE 8.0.0 or ProTools TDM 8.0.0 (or later)

AAX

  • Mac OSX 10.8 or later

  • Pro Tools 11 or later

*If you are using an older operating system please contact us to get access to previous versions of the product compatible with earlier systems.